FrenchTech SAAS
33.5K views | +5 today
FrenchTech SAAS
Les news de l'univers SAAS et FrenchTech
Curated by Mickael Ruau
Your new post is loading...
Your new post is loading...

Popular Tags

Scooped by Mickael Ruau
August 21, 2013 8:21 AM
Scoop.it!

Comprendre les noms chinois

Les chinois placent le nom de famille en premier lieu, suivi du prénom. Une tradition millénaire veut que la plupart des noms de famille chinois ne comptent
qu'un seul caractère. De nos jours on compte environ 3050 noms de famille en Chine.
No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:17 AM
Scoop.it!

max - What is the maximum length of a valid email address? - Stack Overflow

Mickael Ruau's insight:

The correct answer of 254 has now been accepted by the IETF following the erratum I submitted here.

You can get a full diagnosis of any given address here.

The original version of RFC 3696 did indeed say 320 was the maximum length, but John Klensin subsequently accepted this was WRONG.

The maximum length is specified in RFC 5321: "The maximum total length of a reverse-path or forward-path is 256 characters"

RFC 3696 was corrected here

I note for the record that John Klensin may actually be wrong in his correction: a Path is defined as

Path = "<" [ A-d-l ":" ] Mailbox ">"

So the Mailbox element (i.e. the email address) has angle brackets around it to form a Path, so the Mailbox must be no more than 254 characters to keep the path under 256.

I've now collated test cases from Cal Henderson, Dave Child, Phil Haack, Doug Lovell and RFC 3696. 158 test addresses in all.

I ran all these tests against all the validators I could find. The comparison is here: http://www.dominicsayers.com/isemail

I'll try to keep this page up-to-date as people enhance their validators. Thanks to Cal, Dave and Phil for their help and co-operation in compiling these tests and constructive criticism of my own validator.

People should be aware of the errata against RFC 3696 in particular. Three of the canonical examples are in fact invalid addresses.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:14 AM
Scoop.it!

Les noms de famille au Québec : aspects statistiques et distribution spatiale

Institut de la statistique - Historique et Mission
Mickael Ruau's insight:

Fichier 2 (295 ko) Annexe 1 Les 1 000 premiers noms de famille selon le rang
Annexe 2 Les 5 000 premiers noms de famille par ordre alphabétique
Annexe 3 Les 50 noms de famille les plus fréquents par MRC
Annexe 4 Les 50 noms de famille les plus fréquents par région administrative

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:09 AM
Scoop.it!

Cadre d’Interopérabilité des Systèmes d’Information de Santé (CI-SIS) | esante.gouv.fr, le portail de l'ASIP Santé

Cadre d’Interopérabilité des Systèmes d’Information de Santé (CI-SIS) | esante.gouv.fr, le portail de l'ASIP Santé | FrenchTech SAAS | Scoop.it

Les spécifications et outils du CI-SIS sont modulaires et répartis en trois couches :

Une couche de Contenus interopérables, qui concentre les moyens de l’interopérabilité sémantiqueUne couche de Services d’interopérabilitéUne couche de Transport
Mickael Ruau's insight:

L’ensemble des composants de la version courante sont téléchargeables directement au bas de cette page, sous la rubrique « Documents associés », à l'exception de la terminologie SNOMED 3.5 VF et du référentiel LOINC biologie qui sont téléchargeables depuis leurs pages respectives (accessibles depuis la rubrique « Liens associés » ci-dessous).

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:04 AM
Scoop.it!

RGI - interopérabilité | modernisation.gouv.fr

Le RGI est un cadre de recommandations référençant des normes et standards qui favorisent l'interopérabilité au sein des systèmes d'information de l'administration.
Ces recommandations constituent les objectifs à atteindre pour favoriser l'interopérabilité. Elles permettent aux acteurs cherchant à interagir et donc à favoriser l'interopérabilité de leur système d'information, d’aller au-delà de simples arrangements bilatéraux.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:00 AM
Scoop.it!

UK Government Data Standards Catalogue

The e-Government Interoperability Framework (e-GIF) mandates the adoption of XML and the development of XML schemas as the cornerstone of the government interoperability and integration strategy. A key element in the development of XML schemas is an agreed set of data standards

Mickael Ruau's insight:
Usage GuidelinesThis is a copy of the CV bits of the GDSC as published on the e-GIF website. It is not published or maintained by the e-GIF team (at present) so should not be regarded as definitive. Refer instead to their website.
No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:56 AM
Scoop.it!

[ARCHIVED CONTENT] GovTalk – Data Standards

Tranformational Government is part of the Cabinet Office and works to ensure that IT supports the business transformation of government itself so that government can provide better and more efficient public services.
Mickael Ruau's insight:

The e-Government Interoperability Framework (e-GIF) mandates the adoption of XML and the development of XML schemas as the cornerstone of the government interoperability and integration strategy. A key element in the development of XML schemas is an agreed set of data standards.

The Government Data Standards Catalogue sets out the rationale, approach and rules for setting and agreeing the set of Government Data Standards (GDS) to be used in the schemas and other interchange processes. It also contains the standards agreed to date. These standards are also recommended for data storage at the business level. The Catalogue comprises 2 volumes:

Volume 1, this Volume, sets out the general principles, i.e. the rationale, approach and rules for setting standards

Volume 2 sets out the Data Types and Data Items standards. The source for this is an XML document which is published as HTML files or as a PDF file on the Govtalk website.

The Government Data Standards Catalogue can be found at GDSC Online or the HTML files can be downloaded at GDSC .ZIP

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:49 AM
Scoop.it!

Filename - Wikipedia, the free encyclopedia

A filename (also written as two words, file name) is a name used to uniquely identify a computer file stored in a file system. Different file systems impose different restrictions on filename lengths and the allowed characters within filenames.

A filename may include one or more of these components:

The components required to identify a file varies across operating systems, as does the syntax and format for a valid filename.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:45 AM
Scoop.it!

Code du travail - Article ANNEXE | Legifrance

Tailles de champs de données utilisées par l'administration française.

Mickael Ruau's insight:

Lieu de naissance :  Longueur : 26 ;

Titre (M. Mme...) : Longueur : 3 ;

Nom de famille : Longueur : 30 ;

Prénom  : Longueur : 20 ;

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 6:36 AM
Scoop.it!

Démythifier le GROUP BY

Démythifier le GROUP BY | FrenchTech SAAS | Scoop.it

Il existe une légende populaire à propos de la clause SQL GROUP BY. Cette légende soutient que la "norme SQL" impose, dans une requête, que les colonnes référencées dans la liste du SELECT apparaissent également dans la clause GROUP BY, à moins que ces colonnes n'apparaissent exclusivement dans une expression d'agrégation. MySQL est souvent accusé de violer cette norme.
Dans cet article, je vais tenter de briser ce mythe et d'apporter par la même occasion un regard plus mesuré sur le traitement du GROUP BY dans MySQL.

 

 

Mickael Ruau's insight:

"Pour ce faire, je vais d'abord démontrer que MySQL peut être configuré pour accepter des clauses GROUP BY qui ne comportent que des colonnes dans la liste du SELECT contenues dans des fonctions d'agrégation, rapprochant ainsi le comportement de MySQL de celui des autres célèbres SGBDR.
Ensuite, je vais montrer qu'il est très important de bien préciser à quelle version de la norme SQL on fait référence. Les deux versions les plus récentes présentent une définition plus sophistiquée de la relation entre les expressions contenues dans le GROUP BY et la liste du SELECT. Contrairement à une croyance populaire, ces normes n'imposent pas noir sur blanc que toutes les colonnes non contenues dans les fonctions d'agrégation de la liste du SELECT apparaissent dans la clause GROUP BY."

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 4:59 AM
Scoop.it!

ISO/CEI 11179 - Wikipédia

La norme ISO/CEI 11179, connue initialement comme la norme de registre de métadonnées, est une norme de représentation des métadonnées pour une organisation dans un registre de métadonnées.

Cette norme est fortement recommandée par les agences d'État et fédérales des États-Unis, comme le site Web XML du gouvernement des États-Unis.

Les premières versions ont été publiées par l'ISO en 1994 (métamodèle). Début 2007, la norme n'est disponible qu'en anglais.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 4:58 AM
Scoop.it!

Contrôle syntaxique d'une adresse email sur ExpReg

Mickael Ruau's insight:

Un regex pour contrôler une adresse email en respectant la RFC822.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 4:53 AM
Scoop.it!

PHP - Vérifier le format d'une adresse mail

PHP - Vérifier le format d'une adresse mail | FrenchTech SAAS | Scoop.it
Il existe plusieurs manières de déterminer si une variable contient une adresse email valide. Ces techniques ne vérifient pas si l'adresse email existe bien mais elles déterminent si la chaine contenue dans une variable respecte bien le format...
No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:18 AM
Scoop.it!

List of standard lengths for database fields - Stack Overflow

Does anyone have a list of reasonable lengths for the most common fields, such as first name, last name, and email address?

Mickael Ruau's insight:
69 down vote

I just queried my database with millions of customers in the USA.

The maximum first name length was 46. I go with 50. (Of course, only 500 of those were over 25, and they were all cases where data imports resulted in extra junk winding up in that field.)

Last name was similar to first name.

Email addresses maxed out at 62 characters. Most of the longer ones were actually lists of email addresses separated by semicolons.

Street address maxes out at 95 characters. The long ones were all valid.

Max city length was 35.

This should be a decent statistical spread for people in the US. If you have localization to consider, the numbers could vary significantly.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:15 AM
Scoop.it!

Choix du nom de famille d'un enfant : nom de la mère, du père ou double-nom - Service-public.fr

Choix du nom de famille d'un enfant : nom de la mère, du père ou double-nom - Service-public.fr | FrenchTech SAAS | Scoop.it
Les parents peuvent choisir, sous certaines conditions, quel nom portera leur enfant. Une déclaration conjointe de choix de nom peut être faite avant
Mickael Ruau's insight:

Depuis 2005, un enfant dont la filiation est établie à l'égard de chacun des parents, peut porter : 

soit le nom du père,

soit le nom de la mère,

soit les 2 noms accolés dans un ordre choisi par eux et dans la limite d'un seul nom de famille pour chacun s'ils portent eux-mêmes le nom de leurs 2 parents.

À noter :  les noms composés existant avant 2005 constituent un nom unique, qui est indissociable et est donc transmis intégralement.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:13 AM
Scoop.it!

Pourquoi les noms malgaches sont-ils si longs? | Slate Afrique

Pourquoi les noms malgaches sont-ils si longs? | Slate Afrique | FrenchTech SAAS | Scoop.it
Parce qu'ils en disent long sur ceux qui les portent. Une histoire, un destin, un vœu inscrit au plus profond de soi. Mais les temps ont changé.
Mickael Ruau's insight:

Originellement, à Madagascar, il n’y a pas de noms patronymiques que l’on se transmet au sein d’une même famille: un nom se rattache à un individu unique. Il n'est pas rare de constater que des frères et soeurs ne portent pas le même nom. C' est surtout vrai au sein des anciennes générations de Malgaches.

Le choix et l’attribution d’un nom à un enfant, généralement par les parents, relève de divers critères et circonstances. Reste qu'il n’y a pas de règles communes partagées dans toute l’île, empreinte d’une diversité culturelle remarquable.

(...)

Traditionnellement, les noms malgaches présentent une autre spécificité originale: ils ne sont pas forcément permanents. En effet, le Malgache peut tout au long de sa vie changer de nom: à sa naissance, lors de la circoncision pour les garçons, à l'âge adulte, après son mariage, à la naissance de son premier enfant, et même à sa mort. L’octroi d’un nom potshume était une tradition officielle dans la royauté merina mais aussi chez les Sakalava, vivant dans tout l'ouest de Madagascar.

Tous les noms malgaches ne sont pas aussi longs que certains veulent le croire. Des Rakoto et Rabe foisonnent, et peuvent être comparés à des noms français comme Dupont et Martin.

Ce sont les habitants des hauts-plateaux, issus des ethnies merina et betsileo, qui détiennent la palme de la longueur. Et parmi eux, les souverains et lignées royales se distinguent nettement. Le plus illustre d’entre eux, qui a unifié l’ensemble des princes merinas et, au-delà, étendu fortement son territoire par conquête ou par alliance au XVIIIe siècle, est connu sous le nom d’Andrianampoinimerina, «le prince désiré par l’Imerina».

Mais le champion toutes catégories est un prince qui a régné de 1650 à 1670, répondant au nom d'Andriantsimitoviaminandriandehibe. Trente et une lettres qui signifient «le prince qui n’est pas semblable aux autres grands princes» —comprendre qu'il est «mieux». Quant à sa fille aînée, elle s’appelle Ranavalontsimitoviaminandriana, un nom qui présente un air de famille évident. Pourtant, les femmes malgaches, notamment en pays merina, ne portent pas le nom de leur père.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:07 AM
Scoop.it!

Archivage numérique | modernisation.gouv.fr

Archivage numérique | modernisation.gouv.fr | FrenchTech SAAS | Scoop.it

Le développement des technologies de l'information et de la communication a profondément modifié les méthodes de travail en facilitant et en accélérant considérablement la production, le partage et le stockage d'informations numériques. En parallèle, la reconnaissance de l’écrit électronique comme preuve en 2000 a ouvert la voie à l’« administration électronique », à la dématérialisation des processus métier et à la production d''originaux numériques.

Mickael Ruau's insight:

Le standard d'échange de données pour l'archivage (SEDA)Le standard d'échange de données pour l'archivage : http://www.archivesdefrance.culture.gouv.fr/seda/Les schémas XML : http://www.archivesdefrance.culture.gouv.fr/seda/schemas.htmlLes spécifications écrites (pdf, actuelle version et version antérieure) :http://www.archivesdefrance.culture.gouv.fr/seda/documentation/SEDA_description_standard_v1_0.pdfhttp://www.archivesdefrance.culture.gouv.fr/seda/documentation/archives_echanges_v0-2_description_standard_v1-2_revision1.pdf

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 8:03 AM
Scoop.it!

e-GIF - Wikipedia, the free encyclopedia

e-GIF is the UK eGovernment Interoperability Framework.[1]

It is an ambitious exercise intended to resolve and prevent (or at least minimise) problems arising from incompatible content of different computer systems.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:57 AM
Scoop.it!

[ARCHIVED CONTENT] GovTalk

Transformational Government is part of the Cabinet Office and works to ensure that IT supports the business transformation of government itself so that government can provide better and more efficient public services.
No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:51 AM
Scoop.it!

Caractères interdits dans les noms de fichiers Windows

Caractères interdits dans les noms de fichiers Windows | FrenchTech SAAS | Scoop.it
Caractères interdits et autres conventions de nommage des fichiers dans Windows : Les noms de fichiers ne peuvent pas utiliser n'importe quels caractères ni avoir n'importe quelle longueur...

 

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 7:47 AM
Scoop.it!

Naming Files, Paths, and Namespaces (Windows)

All file systems supported by Windows use the concept of files and directories to access data stored on a disk or device. Windows developers working with the Windows APIs for file and device I/O should understand the various rules, conventions, and limitations of names for files and directories.

Data can be accessed from disks, devices, and network shares using file I/O APIs. Files and directories, along with namespaces, are part of the concept of a path, which is a string representation of where to get the data regardless if it's from a disk or a device or a network connection for a specific operation.

Some file systems, such as NTFS, support linked files and directories, which also follow file naming conventions and rules just as a regular file or directory would. For additional information, see Hard Links and Junctions and Reparse Points and File Operations.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 6:40 AM
Scoop.it!

Les petits papiers de SQLPro - Normes de données

Les petits papiers de SQLPro - Normes de données | FrenchTech SAAS | Scoop.it
Le langage de requète SQL, décrit en long en large et en travers... Normes de données
Mickael Ruau's insight:

De nombreuses normes de données existantes, comme certaines règles ou certains usages, sont bien souvent ignorées des développeurs. Cet article en présente quelques unes afin de sensibiliser le lecteur à leur utilisation.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 5:04 AM
Scoop.it!

ISO 15836 - Wikipédia

L'ISO 15836:2009 (fév. 2009) (et son rectificatif ISO 15836/AC1:2009) est une norme internationale qui décrit l'ensemble des éléments de métadonnées Dublin Core qui traitent de la description de ressources informatiques. Son intitulé est « Information et documentation - L'ensemble des éléments de métadonnées Dublin Core ». C'est la nouvelle version de la norme de 2003.

Elle correspond au tronc commun de métadonnées adopté par le gouvernement américain en 1995 (voir Dublin Core).

Cette norme est applicable à toute application informatique qui contient des métadonnées pour l'interopérabilité et l'accès aux ressources informatiques (traçabilité, gestion de la preuve, comptabilisation, archivage…), couplée avec la norme ISO/CEI 11179 sur les registres de métadonnées.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 4:59 AM
Scoop.it!

ISO 13616 - Wikipédia

ISO 13616:2007 est une norme internationale intitulée Banque et services financiers connexes — Numéro de compte bancaire international (IBAN) élaborée par l'Organisation internationale de normalisation (ISO) et le Comité Européen des Standards Bancaires (European Committee for Banking Standards — ECBS) devenu Conseil Européen des Paiements (European payment council ECP)[1].

IBAN est l'acronyme d'international bank account number.

La norme spécifie les éléments du numéro de compte bancaire du bénéficiaire de paiements transfrontaliers. Elle permet une identification homogène des comptes bancaires dans tous les pays, identifie de manière unique un compte bancaire quel que soit l'endroit où il est tenu. Elle est utilisée pour faciliter le traitement automatisé des paiements transfrontaliers.

No comment yet.
Scooped by Mickael Ruau
August 21, 2013 4:56 AM
Scoop.it!

Get MySQL date in RFC-822 format for RSS feeds

Get MySQL date in RFC-822 format for RSS feeds | FrenchTech SAAS | Scoop.it
To get the PubDate element of an RSS feed to validate, it needs to be in RFC-822 format. MySQL has flexible ways of working with dates and times which make this a simple task. Given a datetime colu...
No comment yet.